DokuWiki Prosemirror Plugin

A modern approach on DokuWiki WYSIWYG

Benutzer-Werkzeuge

Webseiten-Werkzeuge


de:start

DokuWiki Prosemirror Plugin

Das Prosemirror Plugin ist ein neues WYSIWYG Plugin für DokuWiki. Wir haben es komplett neu entwickelt - mit einem klaren Fokus auf die Features von DokuWiki. Anders als andere Plugins wandelt es nicht einen bestehenden HTML-Editor wie CKEditor um. Stattdessen basiert es auf dem abstrakten Dokumenten-Ansatz des prosemirror Toolkit. Sie können mehr erfahren warum wir glauben, dass dies der bessere Ansatz für WYSIWYG ist.

Das Prosemirror DokuWiki Plugin wurde von CosmoCode entwickelt – eine Berliner Softwareagentur mit jahrelanger Erfahrung in DokuWiki. CosmoCode bietet DokuWiki Services von Beginn an und hat über die Jahre über 100 freie und Open Source Plugins entwickelt.

FAQ

:?: Wo kann ich das Plugin ausprobieren?

:!: Direkt hier im Wiki. Besuchen Sie den Spielplatz und bearbeiten Sie die Seite. Sie können jederzeit zwischen WYSIWYG und Syntax wechseln.

:?: Wie ist der aktuelle Entwicklungsstand des Plugins? Kann man es produktiv einsetzen?

:!: Das Plugin ist momentan in der Lage mit Standard-DokuWiki-Syntax umzugehen. Für das Gallery Plugin haben wir eine Beispiel-Integration entwickelt. Es gibt jedoch mit Sicherheit noch diverse Bugs und Eigenheiten die wir noch nicht entdeckt haben. Sie können auf der Roadmap sehen welche Bereiche noch komplett fehlen. Wir raten momentan noch von einem Produktiveinsatz ab.

:?: Wie installiere ich das Plugin?

:!: Das Plugin von https://github.com/cosmocode/dokuwiki-plugin-prosemirror/archive/release.zip herunter geladen werden (Sie können diese URL im Extension-Manager verwenden). Bitte bedenken Sie, dass es sich um eine Entwicklungsversion handelt. Sie benötigen außerdem einen aktuellen Development-Snapshot von DokuWiki, da sonst einige Features nicht funktionieren werden.

:?: Arbeitet CosmoCode weiter an diesem Plugin?

:!: Wir würden gerne, dafür müssen wir aber einen Weg zur Quer-Finanzierung unserer Aufwände finden. Erfahren Sie wie Sie helfen können hier.

:?: Welche Browser werden unterstützt?

:!: Das Plugin benötigt modernen JavaScript Support. Es sollte mit allen aktuellen Versionen von Chrome, Firefox, Edge, Safari sowie Internet Explorer 11 funktionieren.

:?: Ich habe einen Bug gefunden! Wie gebe ich am besten Feedback?

:!: Bitte lesen Sie hier wie Sie helfen können.
de/start.txt · Zuletzt geändert: 2018/07/31 16:37 von Michael Große